wpa_supplicant: Could not read interface p2p-dev-wlp3s0 flags

If you get the following message, after having installed wpa_supplicant 1:2.5-1:

# wpa_supplicant -D nl80211,wext -B -i wlp3s0 -c <(wpa_passphase b***5 n***y)

Successfully initialized wpa_supplicant
Could not read interface p2p-dev-wlp3s0 flags: No such device

or you get the same warning using the command wifi-menu, this issue is due to this bug where foutrelis give us this patched version of wpa_supplicant that should solve the problem!

However, the fastest alternative solution is to downgrade the package at the release 2.3.

That’s all! GWH!

About Daniele Dalla Torre

I'm a Civil Engineering student but I love to learn everything about technology, from the basics to the new frontiers! Here my gpg public key!

Leave a Reply

Your email address will not be published.

*