Get a site

Lambda expressions are allowed only at source level 1.8 or above

Lambda expressions allowed source level 1.8

I’m working on a new Java project and I set up my Arch Linux operating system to have both Java Development Kit 1.7 and 1.8 coexisting at the same time. I tried using lambda expressions writing source code with my Eclim (Vim + Eclipse) system while I got the error Lambda expressions are allowed only at source level 1.8 or above.

“Damn, what’s happening!” was my first expression…:D:D:D


Anyway, the OpenJDKfirst thing I thought was about a conflict between OpenJDK 7 and OpenJDK 8. I uninstalled OpenJDK 8 and I run eclim again. Same error.

“What the hell!!!”…my second expression…:D:D:D:D:D


Googling a little bit, I found a guy with my same problem. The real solution is easier than expected: just clean up the workspace, remove it and than starting eclim, allow it to create the new one.


Enjoy guys and happy hacking!


Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 4.0 International License.

Published by Francesco Serafin

I am a PhD student at the Department of Civil, Environmental and Mechanical Engineering at the University of Trento. My two greatest loves: Computer Science and Water (take three with my Lenovo!:D). As a result, the aim of my life is to make both passions coexist. My gpg public key available at

Leave a Reply

Your email address will not be published.

%d bloggers like this: