#4 – ‘Error with pre-create check’ – Docker Toolbox error

Problem When your run Docker Quickstart Terminal for the first time it runs the default machine. So download the boot2docker.iso if not found in the directory. Sometimes this error pop up, on Windows the log is similar to that: I haven’t understood what exactly create this error, but I thing Continue reading #4 – ‘Error with pre-create check’ – Docker Toolbox error

Docker Toolbox for Windows OS – install and troubleshooting

Introduction Here you can find how to install Docker Toolbox for Windows OS. Firstable, if you haven’t already check the prerequisites to install Docker for Windows, please read this post before starting installation. Installation on Windows OS For the installation is difficult to do better then Docker team, so follow Continue reading Docker Toolbox for Windows OS – install and troubleshooting

Lambda expressions are allowed only at source level 1.8 or above

I’m working on a new Java project and I set up my Arch Linux operating system to have both Java Development Kit 1.7 and 1.8 coexisting at the same time. I tried using lambda expressions writing source code with my Eclim (Vim + Eclipse) system while I got the error Continue reading Lambda expressions are allowed only at source level 1.8 or above

Hidden files in linux: how to move them between folders

How to move hidden files from a folder to another? This is a pretty trivial question. I’m a Linux user, so I want to do that via CLI of course. The command is really really simple, but it includes a small trick: The trick is [!.] written after the . Continue reading Hidden files in linux: how to move them between folders

Building QGIS: Could not find a package configuration file provided by “QJSON”

I was building QGIS source code on my own laptop when I got the following warning during the configuration of the CMake files This is an already opend issue at the QGIS Bug report #14982 and fixing it is really simple: just install the gjson library via Then remove the Continue reading Building QGIS: Could not find a package configuration file provided by “QJSON”

xf86-input-synaptics and ThinkPad T440s touchpad

Hello everyone! After the upgrading of the Arch Linux packages on my Lenovo ThinkPad T440s the touchpad did’t work as before. That was due to xf86-input-synaptics fault! For a better understanding, I could not use two finger to copy/paste anymore and in order to left click I needed to push Continue reading xf86-input-synaptics and ThinkPad T440s touchpad

Enable/Disable Touch-Screen on Arch Linux

Since Linux Kernel 3.2, multitouch devices are handled by the hid-multitouch module. Thus, normally, the touchscreen device of a pc is supported by the newest kernels. To verify that, you have to use the xinput command via bash and obtain a result like the following. where the highlighted row show Continue reading Enable/Disable Touch-Screen on Arch Linux